Web制作を行う全ての方へ

PHP4でPHP5の関数を使うためのライブラリ upgrade.php

PHPを組むときはいつも使っているサーバーがPHP5に対応している所ばかりだったので今までは気にしていなかったのですが、今主に仕事をしているサイトのサーバーのPHPがPHP4.4.8というバージョンということもありこれまでと同じようには行かなくなってきました。
PHP5では動く関数がPHP4では動かない事や、オブジェクト指向プログラミングもPHP4ではそのままでは動かないなどの問題点があり、現在色々四苦八苦しています。
一先ずせめてPHP5の関数をサクっとPHP4で使える方法が無いかな?と思っていたところ、ツイッターでこれはどう?というふうに勧められたライブラリが「upgrade.php」というものでした。
導入が簡単にでき、ある程度の関数ならそのまま使えるというのがとても有りがたいライブラリ集です。

ライブラリ入手先
http://upgradephp.berlios.de/
※何故かインターネットエクスプローラーでは開けません。

使い方は

といった1行を挿入するだけ。念のためif文等でPHPのバージョンが4の時のみ利用するといった処理をしていた方が良いかも知れません。

Ad



Comments

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です